Kann CDT bei Eclipse Indigo nicht installieren



  • Ich habe bisher Ubuntu 11.04 genutzt und hatte darauf Eclipse Helios (3.6) mit dem CDT-Plugin und das hat auch funktioniert.
    Vorgestern habe ich Ubuntu auf 11.10 aktualisiert und dabei wurde auch Eclipse automatisch auf Indigo (3.7) gebracht. Dabei funktioniert CDT nicht mehr. Ich habe Eclipse dann deinstalliert und neu installiert und wollte dann nochmal das CDT Plugin installieren. Ich finde es auch für Indigo, aber wenn ich die Sachen auswähle, die ich brauche und dann installieren will bekomme ich eine Fehlermeldung:

    Cannot complete the install because of a conflicting dependency.
    Software being installed: C/C++ Development Platform 8.0.0.201106081058 (org.eclipse.cdt.platform.feature.group 8.0.0.201106081058)
    Software being installed: C/C++ Development Tools SDK 8.0.0.201109151620 (org.eclipse.cdt.sdk.feature.group 8.0.0.201109151620)
    Only one of the following can be installed at once:
    C/C++ Development Platform 8.0.0.201109151620 (org.eclipse.cdt.platform.feature.jar 8.0.0.201109151620)
    C/C++ Development Platform 8.0.0.201106081058 (org.eclipse.cdt.platform.feature.jar 8.0.0.201106081058)
    Cannot satisfy dependency:
    From: C/C++ Development Tools 8.0.0.201109151620 (org.eclipse.cdt.feature.group 8.0.0.201109151620)
    To: org.eclipse.cdt.platform.feature.group [8.0.0.201109151620]
    Cannot satisfy dependency:
    From: C/C++ Development Platform 8.0.0.201106081058 (org.eclipse.cdt.platform.feature.group 8.0.0.201106081058)
    To: org.eclipse.cdt.platform.feature.jar [8.0.0.201106081058]
    Cannot satisfy dependency:
    From: C/C++ Development Platform 8.0.0.201109151620 (org.eclipse.cdt.platform.feature.group 8.0.0.201109151620)
    To: org.eclipse.cdt.platform.feature.jar [8.0.0.201109151620]
    Cannot satisfy dependency:
    From: C/C++ Development Tools SDK 8.0.0.201109151620 (org.eclipse.cdt.sdk.feature.group 8.0.0.201109151620)
    To: org.eclipse.cdt.feature.group [8.0.0.201109151620]

    Weiß einer was ich da tun kann? Ich habs schon mehrfach versucht.

    Übrigens würde ich drauf bestehen auch Indigo zu nutzen aus Komfortgründen. Indigo wird wirklich installiert und ich kann es per Suche aufrufen etc. Helios kann ich nur irgendwie irgendwo in einen Ordner entpacken und es wird von Ubuntu nicht als installierte Software erkannt.



  • Jolka schrieb:

    Weiß einer was ich da tun kann?

    Nimm die Pakete direkt von der Eclipse Webseite und installier es manuel.
    Einfach entpacken und mit root Rechten nach /opt verschieben.

    Eclipse aus dem Ubuntu Repo hat noch nie gut funktioniert und ist IMO auch all zu oft veraltet.



  • Sorry, bin absoluter Ubuntu-Neuling.

    Wo finde ich /odt und wie kann ich es mit root-Rechten verschieben?



  • Hi,

    einfach unter eclipse.org -> Downloads dein Packet runterladen, dann

    mittels

    sudo tar -zxvf eclipse-xxx.tar.gz -C /opt

    also ins Verzeichnis /opt entpacken, dann kann man mittels

    /opt/eclipse/eclipse &

    starten, bzw. du kannst dir einen Starter im Launcher erstellen. Z.B. einfach eine Datei erstellen in .local/share/applications mit dem Namen eclipse.desktop und folgendem Inhalt:

    [Desktop Entry]
    Version=1.0
    Type=Application
    Terminal=false
    Exec=/opt/eclipse/eclipse
    Name=Eclipse C/C++
    Comment=Eclipse für C/C++ Entwicklung
    Icon=[Pfad für Icon-Bild]

    Danach diese Datei in den Launcher ziehen.
    Gruß


Log in to reply