Launch failed. Binary not found! C++ Project



  • Hallo,

    ich habe leider oft Probleme Programme auszuführen, auch wenn diese fehlerfrei sind.
    Ich lege in Eclipse ein C++ Project an und füge dann eine Source File hinzu. Oft bekomme ich jedoch die im Betreff beschriebene Fehlermeldung. Wenn ich das Programm kopiere und in einem anderem C++ Project mit neuer Source File anlege, wird dieses ausgeführt. Die Einstellungen sind die gleichen. Oft muss ich mehrere C++ Projects anlegen bis das Programm endlich funktioniert. An was kann das liegen?



  • Ich habe die Erfahrung gemacht, dass - auch wenn ich Microsoft-Software meide wo es nur geht - Visual Studio das einzige ist was unter Windows problemlos läuft. Alles andere bedarf gesonderter Konfiguration bis ins kleinste Detail oder aber hat hier und da macken. Die Community-Edition (welche vom Funktionsumfang einer Professional gleichkommt) ist sogar kostenlos. Falls du bei Eclipse bleiben möchtest wäre es gut, mal den Output beim Kompilieren zu sehen (der müsste in Eclipse im unteren Bereich angezeigt werden). Ich Vermute, dass die Datei zwar existiert aber nicht dem Projekt als zu kompilierende Datei zugewiesen ist.



  • Dieser Thread wurde von Moderator/in SeppJ aus dem Forum C++ (alle ISO-Standards) in das Forum Compiler- und IDE-Forum verschoben.

    Im Zweifelsfall bitte auch folgende Hinweise beachten:
    C/C++ Forum :: FAQ - Sonstiges :: Wohin mit meiner Frage?

    Dieses Posting wurde automatisch erzeugt.



  • Danke für deine Antwort.
    Kann die Meldung (leider) nicht posten, weil es dann auf einmal funktioniert hat.

    Habe jetzt aber ein weiteres Problem, bei dem ich nicht weiß, ob das damit vllt auch etwas zu tun hat. Ich arbeite gerade das Buch Programming Principles and Practice Using C++ durch. Mein Compiler ist GCC und hat die Version 4.9.2. Das folgende Programm funktioniert:

    vector<string> v = { "one", "two", "three" }; 
    for( string s : v ) {   
         cout << s << endl;}
    

    Wenn ich jedoch das folgende Programm ausführen möchte:

    vector<string>words;
        	for (string temp; cin>>temp;)
        		words.push_back(temp);
        	cout << "Number of words: " << words.size() << '\n';
    

    bekomme ich nach der Worteingabe die Fehlermeldung:
    dyld: lazy symbol binding failed: Symbol not found: __ZNSsC1EOSs
    Referenced from: Pfad wo es gespeichert ist
    Expected in: /usr/lib/libstdc++.6.dylib

    dyld: Symbol not found: __ZNSsC1EOSs
    Referenced from: Pfad, wo es gespeichert ist
    Expected in: /usr/lib/libstdc++.6.dylib

    Ich kopiere beide Programme in das gleiche C++ Project und in die gleiche cpp Datei. Pfade müssten eigentlich stimmen, da es ja bei dem einen Programm funktioniert. Woran kann das noch liegen? 😕



  • Jetzt kam es mal wieder zu dem Problem: Launch failed. Binary not found.

    Folgendes wird angezeigt:
    **** Incremental Build of configuration Debug for project Chapt4.0 ****
    make all
    Building file: ../TryThis4.cpp
    Invoking: GCC C++ Compiler
    g++ -O0 -g3 -Wall -c -fmessage-length=0 -std=c++11 -MMD -MP -MF"TryThis4.d" -MT"TryThis4.d" -o "TryThis4.o" "../TryThis4.cpp"
    Finished building: ../TryThis4.cpp

    Building target: Chapt4.0
    Invoking: MacOS X C++ Linker
    g++ -o "Chapt4.0" ./TryThis4.o
    Finished building target: Chapt4.0


Log in to reply