Visual Studio LNK1181 .obj



  • Hallo zusammen

    Ich arbeite schon lange am C++ Projekt. Seit heute bekommen ich folgende Fehlermeldung.

    error LNK1181: Eingabedatei "\.obj" kann nicht geöffnet werden.
    

    Und ja, es steht nur .obj da.
    Ich habe es schon mit google versucht, aber keine passende Antwort gefunden.
    Ich habe am Projekt eigentlich nichts geändert. Andere Projekt kompilieren problemlos. Auch mit Qt Creator wird das Projekt kompiliert werden.
    Ich hoffe ihr könnt mir helfen.

    Danke im voraus 🙂



  • Sillo schrieb:

    Ich habe am Projekt eigentlich nichts geändert.

    Glaub ich nicht.

    Sillo schrieb:

    Und ja, es steht nur .obj da.

    Nein, tut es nicht. Der Linker sagt "\.obj" . Das ist nicht ".obj" .

    Schau mal in deinen Linkereinstellungen nach, ob du da vielleicht einen ungültigen Eintrag in den Eingabedateien hast. Sowas in der Art ";\;" oder ähnliches. Ansonsten paste die Liste einfach mal. Oder direkt die ganze Config.



  • in der Liste der Eingabe ist nichts mit ;\; drin.

    Qt5Ftp.lib;quazip.lib;qtmain.lib;Qt5Core.lib;Qt5Gui.lib;Qt5Network.lib;Qt5Widgets.lib;Qt5Xml.lib;version.lib;$(INHERIT);%(AdditionalDependencies)
    


  • Die Befehlszeile vom Linker

    /OUT:"D:\Win8\c++\TS_MFD\Win32\Release\\TS_MFD.exe" /MANIFEST /NXCOMPAT
    /PDB:"D:\Win8\c++\TS_MFD\Win32\Release\TS_MFD.pdb" /DYNAMICBASE "Qt5Ftp.lib"
    "quazip.lib" "qtmain.lib" "Qt5Core.lib" "Qt5Gui.lib" "Qt5Network.lib"
    "Qt5Widgets.lib" "Qt5Xml.lib" "version.lib" "kernel32.lib" "user32.lib"
     "gdi32.lib" "winspool.lib" "comdlg32.lib" "advapi32.lib" "shell32.lib"
     "ole32.lib" "oleaut32.lib" "uuid.lib" "odbc32.lib" "odbccp32.lib" /MACHINE:X86
     /SAFESEH /PGD:"D:\Win8\c++\TS_MFD\Win32\Release\TS_MFD.pgd" /SUBSYSTEM:WINDOWS
     /MANIFESTUAC:"level='requireAdministrator' uiAccess='false'"
     /ManifestFile:"Release\TS_MFD.exe.intermediate.manifest" /ERRORREPORT:PROMPT
     /NOLOGO /LIBPATH:"D:\Win8\c++\Frameworks\Qt\5.6\msvc2013\lib"
     /LIBPATH:"C:\Program Files (x86)\Visual Leak Detector\lib\Win32" /TLBID:1
    


  • Oh Sorry
    Fehler gefunden. War die falsche Config. Es war doch ein ;/; drin.
    Vielleicht weil ich ein Qt Module hinzugefugt habe und danach weider entfernt. Per Hand habe ich nichts eingetragen.

    Danke für die Hilfe


Log in to reply