Eclipse: Parameter mit Leerzeichen an das Programm übergeben



  • Hallo zusammen,

    ich habe ein Programm geschrieben, dem ich zwei Dateinamen übergeben muss. Ich möchte dazu in Eclipse unter "Run->Run Configurations->Arguments" zwei Parameter angeben. Leider sind in den Dateinamen Leerzeichen enthalten. Eclipse ließt die Parameter immer nur bis zum Leerzeichen und geht dann davon aus, dass der Rest andere Parameter sind.

    Wie kann ich Eclipse mitteilen, dass es sich um zwei Parameter mit Leerzeichen handelt? Wenn ich es wie in der Kommandozeile mit doppelten Anführungszeichen mache, dann wird es so interpretiert, als würde das doppelte Anführungszeichen zum Wert des Übergabeparameters gehören.

    Hier ein Beispiel. Die Parameter
    "C:\Ordner1 mit Leerzeichen\Datei1.txt"
    "C:\Ordner2\Datei2.txt"
    werden als 4 Parameter interpretiert:

    1. "C:\Ordner1
    2. mit
    3. Leerzeichen\Datei1.txt"
    4. "C:\Ordner2\Datei2.txt"


  • Das macht nicht Eclipse, dass ist das default verhalten im System, dass Parameter durch leerzeichen getrennt sind.
    Das gleiche Problem tritt z.b. auch unter Windows auf, wenn du ein Link auf eine exe datei hast und in den Properties des Links Parameter dem Programm mitgeben möchtest.
    Versuch mal die Parameter mit Leerzeichen in Anführungszeichen zu setzen.



  • Hast du auch wirklich die Frage gelesen?



  • @mechanics sagte in Eclipse: Parameter mit Leerzeichen an das Programm übergeben:

    Hast du auch wirklich die Frage gelesen?

    Ja habe ich. Und ich habe auch die "" gesehen im Post. Nur leider sagt das leider überhaupt nichts aus ob das auch so in den Projekt-Settings so drinn steht.



  • Eigentlich sollte es mit den doppelten Anführungszeichen funktionieren.
    Du kannst es aber mal über Variablen probieren: How to pass a literal variable reference (${foo}) as program argument in a run configuration (orientiere dich nicht an der Frage, sondern der Antwort ;- )



  • Danke für die Rückmeldungen. Mit der Verwendung von Variablen hat es auch nicht funktioniert.

    Wie sich herausgestellt hat, habe ich eine inzwischen schon 7 Jahre alte Version von eclipse benutzt, was mir aber erst jetzt aufgefallen ist... Mit der neueren Version Oxygen von 2017 hat es dann wie erwartet mit den Anführungszeichen geklappt.



  • Ich hatte erst noch "Benutzt du evtl. eine ältere Version von Eclipse?" getippt, aber dann wieder wegeditiert - also lag ich doch nicht falsch. 🙂