VS-Code gibt alten Quellcode aus



  • Guten Tag. ich habe ein Problem mit meinen Editor Visual Studio Code.
    Sobald ich mein Programm Debuggen möchte, debuggt er meinen alten Quellcode. Egal ob ich den neuen Quellcode abgespeichert habe oder nicht.
    Ich muss immer wieder Strg Umschalt B drücken , damit ich es anschließend F5 debuggen kann. Erst dann wird mein neu geschriebener Quellcode angenommen. Ich habe schon versucht alles neu zu installieren aber das Problem besteht immernoch.
    c_cpp_properties:

    {
        "configurations": [
            {
                "name": "Win32",
                "defines": [
                    "_DEBUG",
                    "UNICODE"
                ],
                "compilerPath": "D:\\Weiteres\\Mingw\\bin\\g++.exe",
                "intelliSenseMode": "gcc-x64",
                "browse": {
                    "path": [
                        "${workspaceFolder}"
                    ],
                    "limitSymbolsToIncludedHeaders": true,
                    "databaseFilename": ""
                }
            }
        ],
        "version": 4
    }
    

    launch:

    {
        "version": "0.2.0",
         "configurations": [
             {
                 "name": "(gdb) Launch",
                 "type": "cppdbg",
                 "request": "launch",
                 "program": "${workspaceFolder}/marvin.exe",
                 "args": [],
                 "stopAtEntry": false,
                 "cwd": "${workspaceFolder}",
                 "environment": [],
                 "externalConsole": true,
                 "MIMode": "gdb",
                 "miDebuggerPath": "D:\\Weiteres\\Mingw\\bin\\gdb.exe",
                 "setupCommands": [
                     {
                         "description": "Enable pretty-printing for gdb",
                         "text": "-enable-pretty-printing",
                         "ignoreFailures": true
                     }
                 ]
             }
         ]
     }
    

    task:

    {
        "version": "2.0.0",
        "tasks": [
            {
                "label": "marvin",
                "type": "shell",
                "command": "g++",
                "args": [
                    "-g",
                    "-o",
                    "marvin",
                    "marvin.cpp"
                ],
                "group": {
                    "kind": "build",
                    "isDefault": true
                }
            }
        ]
    }
    

    Bild
    Hoffentlich kann mir wer helfen. Dankeschön. Ich möchte einfach wieder normal F5 drücken können. Ich bekomme auch immer diesen Fehler:
    Warning: Debuggee TargetArchitecture not detected, assuming x86_64.
    =cmd-param-changed,param="pagination",value="off"
    Aber das Programm debuggt mit den Fehlercode 0, also alles gut
    The program 'D:\Weiteres\Microsoft VS Code\projekt\marvin.exe' has exited with code 0 (0x00000000).



  • @NewMarvin Hatte mal sowas Ähnliches. Irgendwann habe ich entnervt den Rechner zur Sicherheit geimaged, die Sourcen komplett umkopiert, das Projekt gelöscht, also auch richtig hart per Dateimanager/Regedit und aus den Sourcen neu aufgebaut.
    Hat funktioniert, ich hab' nie wieder drüber nachgedacht.
    Aber versuch's mal mit einem neuen Projekt, in das Du die Sourcen einkopierst als Abkürzung, könnte viel Zeit sparen.

    PS: Achso, hat mit C++ nix zu tun, gehört ins IDE- Forum verschoben.



  • @Sarkast Ok, vielen dank dir. Ich versuchs mal.



  • @NewMarvin Warte noch, das war die Ultima Ratio, vllt. weiß jemand Anderes was Besseres.
    Also, das Erste wäre, die Sourcen in ein anderes Verzeichnis umzuspulen und von da aus das Projekt unter neuem Namen aufzubauen. Das zumindest sollte rasch gehen, wenn's schief geht, nochmal nachhaken.



  • @Sarkast Auch nachdem ich ein neues Projekt erstellt habe, funktionierte es immer noch nicht.



  • @NewMarvin OK, bin gerade blind. VS regt sich nur über fehlende Einstellungen auf, stell halt mal das Target ein. Und schlag "pagination" nach, google sei dein Freund. Das geht ruckzuck. und Du hast ein ungewolltes Backup. 😉

    Äh, worüber reden wir? Ich bin von MS VS ausgegangen, aber da paßt ja gar nix.



  • "preLaunchTask": "build" hat alles gelöst in der launch datei
    in meinen fall nicht build sondern marvin

    
    
    {
        "version": "0.2.0",
        "configurations": [
            
            {
                "name": "(gdb) Launch",
                "type": "cppdbg",
                "request": "launch",
                "program": "D:\\Weiteres\\Microsoft VS Code\\projekt\\a.exe",
                "args": [],
                "stopAtEntry": false,
                "cwd": "${workspaceFolder}",
                "preLaunchTask": "marvin",
                "environment": [],
                "externalConsole": true,
                "MIMode": "gdb",
                "miDebuggerPath": "D:\\Weiteres\\Mingw\\bin\\gdb.exe",
                "setupCommands": [
                    {
                        "description": "Enable pretty-printing for gdb",
                        "text": "-enable-pretty-printing",
                        "ignoreFailures": true
                    }
                ]
               
                
            } 
        ] 
    }
    
    
    
    
    

    Ich bedanke mich für die Hilfe. Schönen Tag noch


Log in to reply