Sfml zeigt kein Bild an



  • Hallo,
    ich bin sehr unerfahren mit C++ und Sfml und möchte, um mein Wissen zu erweitern, ein kleines Spiel schreiben. Bisher soll nur ein Bild angezeigt werden, was nicht funktioniert, mir aber auch keinen Fehler ausgibt.
    Ich gehe mal davon aus, dass mein Code ziemlich schlecht ist, also wenn ihr mir meine Fehler aufzeigen würdet, wäre ich sehr dankbar. https://github.com/DanielSchreiberMendes/SfmlTest

    Danke



  • Du musst schaun das der compiler übereinstimmt anstonsten den Source downloaden und maken ist alles beschrieben ein besseres tutorial findet man nicht



  • @Abe Es hat früher schon mal funktioniert und es öffnet sich auch das Fenster, es wird nur kein Inhalt angezeigt. Man kann damit auch interagieren und alles. Funktioniert es bei dir?



  • hab mir das nicht runter geladen also nein kannst deinen Code auch hier Posten eventuell hast du ein falsches Verzeichnis angegeben oder dein Compiler aktualisiert



  • class Game{
    
    private:
    	sf::RenderWindow window;
    	Player player;
    ...
    
    
    Game::Game(){
    	window.create(sf::VideoMode(200, 200), "Game");
    ...
    void Game::render(){
    	window.clear();
    	player.draw(window);
    	window.display();
    ...
    class Player{
    
    private:
    	int x, y;
    	sf::Texture texture;
    	sf::Sprite image;
    ...
    Player::Player(){
    	texture.loadFromFile("images/player.png");
    ...
    void Player::draw(sf::RenderWindow& window){
    	window.draw(image);
    
    }
    


  • schau dir die Exempels und Tutorials an alle auch offline dabei in Share

     sf::Texture t;
        if(t.loadFromFile("sfml.png")==0)std::cout << "check file";
        sf::RenderWindow window;
        window.create(sf::VideoMode(800,600,32),"main");
        sf::Sprite s;
        s.setTexture(t);
    
    
    
        while(window.isOpen()){
    
                    sf::Event e;
                        while(window.pollEvent(e))
                            if(e.type== sf::Event::Closed) window.close();
    
    
    
                    window.clear(sf::Color::Magenta);
                    window.draw(s);
                    window.display();
    
                    }
    


  • @Abe Ah ich hab den Fehler gefunden. Ich hab texture zwar geladen, aber nicht der Player Sprite zugewiesen


Log in to reply