/windows/C/... Verzeichnis konnte nicht erstell werden.



  • Hi,
    seit meiner WindowsXP neuinstallation (ich habe den Bootmanager etc. neueingerichtet) kann ich antscheinend nicht mehr auf meine Windows Festplatte schreiben. Fehler: /windows/C/DateiVerzeichnis "Verzeichnis konnte nicht erstellt werden", das lesen funktioniert gut.
    Ich benutze SuSE Linux 9.0

    Weis jemand was ich tuen kann?

    Vielen dank im voraus.

    MfG Max



  • Hast du die Festplatte zufällig auf NTFS formatiert?

    -junix



  • jepp, war sie aber vorher auch schon.

    MfG Max



  • AFAIK ist das Schreiben von NTFS unter LInux nach wie vor Experimentell eingestuft. Insofern wage ich zu bezweifeln, dass du Out of the Box NTFS schreiben konntest...

    -junix



  • junix schrieb:

    AFAIK ist das Schreiben von NTFS unter LInux nach wie vor Experimentell eingestuft. Insofern wage ich zu bezweifeln, dass du Out of the Box NTFS schreiben konntest...

    Ich bin mir ziemlich sicher das ich davor auch ne NTFS Partition hatte und ich konnte ohne Probleme schreiben. -Sehe ich das richtig das ich mein System nocheinmal neueinrichten muss?

    Oder gibt es eine andere Lösung?

    MfG Max



  • nur der Kernel muss neu eingerichtet werden. Schau doch mal bitte nach, ob es in /etc/kernels eine passende Datei zu Deinem Kernel gibt und suche dann in dieser Datei nach CONFIG_NTFS_RW. Wenn dahinter kein "y" oder "m" steht, dann musst Du den Kernel tatsächlich mit NTFS-Write-Support neu kompilieren.

    Gruß Jens

    [EDIT]Satz-Sinn wieder hergestellt[EDIT]



  • Sa(n)dman schrieb:

    nur der Kernel muss neu eingerichtet werden. Schau doch mal bitte nach, ob es in /etc/kernels eine passende Datei zu Deinem Kernel gibt und suche dann in dieser Datei nach CONFIG_NTFS_RW. Wenn dahinter kein "y" oder "m" steht, dann musst Du den Kernel tatsächlich mit NTFS-Write-Support neu kompilieren.

    Nicht so beim 2.6.x Kernel. Der unterstuetzt zwar schreiben, aber die Dateigroesse darf nicht veraendert werden, und es darf somit auch nichts neues erstellt werden.
    Das bedeutet, wer wirklich write support benoetigt, sollte sich captive ntfs anschauen. Das funktioniert einwandfrei



  • den hat SUSE in seiner 9.0er IIRC nicht eingebaut. Wozu also die Leute zusätzlich verwirren? Für 2.4.x ist das was ich schrieb schon völlig hinreichend. Allerdings muss ich noch dazu sagen, daß eine FAT32 als Transpherpartition hier immer noch die zuverlässigste Lösung darstellt. Auch mit den nativen Win-Treibern, die Captive da verwendet hab ich schon so von dem ein oder anderen Problem speziell im Bezug auf die Einbindung gehört.

    Gruß Jens



  • Sa(n)dman schrieb:

    den hat SUSE in seiner 9.0er IIRC nicht eingebaut. Wozu also die Leute zusätzlich verwirren?

    Naja - was SuSe als Kernel dabei hat kann ich nicht wirklich sagen, bin seit 2 Jahren gluecklicher Gentoo User. Aber wenn der User selbst einen neuen Kernel einpflegt, kann es eben zu diesem Problem kommen. Besser mehr Informationen, als die, die es vielleicht ist verschweigen. Meinst du nicht?

    cheers,
    Sven



  • Naja, das System habe ich erst gestern eingerichtet.
    Ich will später wenn ich mich mit Linux etwas besser auskenne natürlich auch den Kernel updaten also ist Sa(n)dmans lösung leider nicht die die ich mir vorstelle.
    Ich werde wohl einfach mein Windows neuformatieren und mit FAT32 wird es doch wohl keine Probleme geben. Ich habe ja noch das Backup von gestern. 😃

    Danke an alle.

    MfG Max



  • So, jetzt habe ich FAT32 und den Bootmanager neukonfiguriert.
    Ich kann jetzt auch wieder beides booten, doch leider denkt Linux jetzt,
    das ich noch die NTFS Partition habe. Tut mir echt leid das ich euch die ganze
    Zeit mit Fragen überschütte aber ich weis nicht weiter.

    Wie kann ich Linux verständlich machen das ich nun eine FAT32 Partition habe?
    Der Mountpunkt dürfte ja immer noch: /windows/C sein.
    Ich habe in Yast etc. nichts finden können.

    Vielen dank im voraus.

    MfG Max



  • Ok jetzt kann ich immerhin lesen, das ist der eintrag in der fstab:

    fstab schrieb:

    /dev/hda1 /windows/C vfat 24987MB 22081MB ro,users,gid=users,umask=0002,nls=iso8859-1 00

    Weis jemand was ich falsch mache?

    MfG Max



  • Ich bringe das einfach nicht hin, ich kann nach wie vor jetzt unter FAT lesen aber nicht schreiben.

    Weis jemand was ich tuen kann?
    (Könnte ein kernelupdate den Schaden beheben?)

    danke.

    MfG Max



  • Master_Max schrieb:

    Ok jetzt kann ich immerhin lesen, das ist der eintrag in der fstab:

    fstab schrieb:

    /dev/hda1 /windows/C vfat 24987MB 22081MB ro,users,gid=users,umask=0002,nls=iso8859-1 00

    Weis jemand was ich falsch mache?

    MfG Max

    Wenn du mal
    #man /etc/fstab
    ausgefuehrt haettest, wuesstest du, das das Flag ro = read only heisst. Das was du willst ist rw = Read/Write



  • SnorreDev: Nur man fstab, man /etc/fstab verwendet einfach man als Pager für /etc/fstab und das ist wohl nicht erwünscht. 😉
    Max: Lies auch mal man: mount(8), das dürfte recht aufschlussreich für Dich sein.



  • nman schrieb:

    SnorreDev: Nur man fstab, man /etc/fstab verwendet einfach man als Pager für /etc/fstab und das ist wohl nicht erwünscht. 😉
    Max: Lies auch mal man: mount(8), das dürfte recht aufschlussreich für Dich sein.

    Ups - hast recht - ich tippe manchmal schneller, als mein Hirn denkt 😃



  • Vielen dank funktioniert wunderbar.
    -Ihr habt echt was gut bei mir.

    MfG Max


Log in to reply