Probleme mit PHP Website



  • Hy Leute, erstmal ich liebe dieses Board lerne C++ und bin gerne hier um lösungen zu suchen, diesmal ist es aber etwas im php bereich wovon ich keine ahnung habe. Hab schon in 2 anderen Foren versucht eine antwort zu bekommen ist aber nichts bei rumgekommen. Ich habe eine Website vorliegen die auf php basiert und seit neustem beim laden Fehler meldet, unten finden ihr die Fehlermelungen und den code in dem es auftritt. Solltet ihr die php datein einsehen wollen kann ich sie zuim download anbieten.

    Solltet ihr mehr infos brauchen dann sagst einfach.
    Danke für eure Hilfe im Voraus

    Fehlermeldung 1

    Zeile: 30
    Zeichen: 14
    Fehler: Nicht abgeschlossene Zeichenfolgenkonstante
    Code: 0
    URL: http://www.rosi-reisen.de/main.php

    der Code steht weiter unten

    Fehlermeldung 2
    Zeile: 27
    Zeichen: 1
    Fehler: 'linkset' ist undefiniert
    Code: 0
    URL: http://www.rosi-reisen.de/main.php

    Fehlermeldung 3
    Zeile: 27
    Zeichen: 1
    Fehler: Objekt erwartet
    Code: 0
    URL: http://www.rosi-reisen.de/main.php

    Die Fehlermeldungen wiederholen sich für Zeile 28; 29; 30 und 31

    Ist ist mal der Code für Zeile 27 bis 38 um sich einen besseren eindruck zu verschaffen

    Zeile 27
    </OBJECT><br>

    Zeile 28
    <table width="521" border="0" cellspacing="0" cellpadding="0">

    Zeile 29
    <tr>

    Zeile 30
    <td width="59"><a href="main.php?section=start" target="_top"><img src="images/menue_01_top.gif" width="59" height="21" alt="" border="0"><img src="images/menue_01.gif" width="59" height="13" alt="" border="0"></a></td>

    Zeile 32
    <td width="99"><img src="images/menue_05_top.gif" width="99" height="21" alt="" border="0"><a href="main.php?section=unternehmen" target="_top" onMouseover="showmenu(event,linkset[3])" onMouseout="delayhidemenu()"><img src="images/menue_05.gif" width="99" height="13" alt="" border="0"></a></td>

    Zeile 33
    <td width="90"><img src="images/menue_02_top.gif" width="90" height="21" alt="" border="0"><a href="main.php?section=reisebusse" target="_top" onMouseover="showmenu(event,linkset[0])" onMouseout="delayhidemenu()"><img src="images/menue_02.gif" width="90" height="13" alt="" border="0"></a></td>

    Zeile 24
    <td width="102"><img src="images/menue_04_top.gif" width="102" height="21" alt="" border="0"><a href="main.php?section=routenplanung" target="_top" onMouseover="showmenu(event,linkset[2])" onMouseout="delayhidemenu()"><img src="images/menue_04.gif" width="102" height="13" alt="" border="0"></a></td>

    Zeile 35
    <td width="98"><img src="images/menue_03_top.gif" width="98" height="21" alt="" border="0"><a href="main.php?section=reiseangebote" target="_top" onMouseover="showmenu(event,linkset[1])" onMouseout="delayhidemenu()"><img src="images/menue_03.gif" width="98" height="13" alt="" border="0"></a></td>

    Zeile 36
    <td width="73"><img src="images/menue_06_top.gif" width="73" height="21" alt="" border="0"><a href="main.php?section=kontakt" target="_top" onMouseover="showmenu(event,linkset[4])" onMouseout="delayhidemenu()"><img src="images/menue_06.gif" width="73" height="13" alt="" border="0"></a></td>

    Zeile 37
    </tr>

    Zeile 38
    </table><br>

    Zeile 31 ist eine leerzeile, vor jedem <td width... sind 16 Leerzeichen nur falls es wichtig ist.



  • Steht das, was du oben als Code angegeben hast alles in den <?php ?> tags?

    Weil dann gibt es ja fehler weil er ein " als textanfang und ein " als textende nimmt, d.h. du musst vor jedes " was im text vorkommt (höhenangaben etc) ein \ setzen, sofern du das mit echo angibst.

    Am besten wäre es aber, du gibst tatsächlich den gesamten code an, damit man da mal in ruhe stöbern kann 😉

    Liebe grüsse



  • Bist du sicher, dass das PHP-Fehlermeldungen sind - liest sich irgendwie eher wie JavaScript-Fehler 🙄



  • Ihr könnt euch gerne mal die website runterladen hab den link am ende gepostet und mal gucken obs nun java oder php fehler sind ich weiß es nämlich nicht.

    www.rosi-reisen.de/website.rar



  • Mal ne ganz andere frage, die Fehler treten auch bei der Onlineversion, die du oben verlinkt hast auf?

    Weil bei mir kommt da keine Fehlermeldung...

    BTW: Javascript - fehlermeldungen werden für gewöhnlich durch ein popupfenster gemeldet, während php - fehler direkt auf der seite erscheinen.

    Liebe grüsse



  • Bei einigen scheinen die Fehlermeldungen nicht aufzutreten, darum schildere ich mal kurz das Problem was nicht geht ob fehlermeldungen erscheinen oder nicht. Alo auf der hauptseite gibt es oben zur navigation einige Puntke Home Reiseflotte usw. sobald die maus darüber rollt sollte eigentlich ein menü mit unterpunkten aufgehen, hab seit kurzem geht das nicht mehr. Weiß jemand warum?



  • Das sind dann JavaScript-Fehler - was hast du denn am Script geändert?



  • Ichhatte eine neue section eingetragen, als ich gemerkt habe das das fehlermeldungen gibt hab ich die zeile wieder gelöscht aber die fehlermeldungen sind immer noch da. hab über phpmyadmin die section hinzugefügt und gelöscht. ich bin echt am verzweifeln. 😞



  • In deinem menue.php ist bei linkset[3] der Output bzgl. der Zeilenumbrüche nicht ganz in Ordnung:

    linkset[3]='<div class="menuitems"><a href="main.php?section=unternehmen" target="_top">Unternhemen</a></div>'
    linkset[3]+='<div class="menuitems"><a href="main.php?section=geschichte" target="_top">Geschichte</a></div>'
    linkset[3]+='
    <div class="menuitems"><a href="main.php?section=news" target="_top">News</a><br>
      ' linkset[3]+='<br>
      <a href="main.php?section=presse" target="_top">Presseberichte<br>
      </a>' linkset[3]+=' </div>
    <div class="menuitems"><a href="main.php?section=jobs" target="_top">Jobs</a></div>'
    linkset[3]+='<div class="menuitems"><a href="main.php?section=partner" target="_top">Partner-Links</a></div>'
    

    Ich könnte mir vorstellen, dass dadurch der Interpreter durcheinanderkommt 🤡



  • Ist das jetzt ein DB basierendes Dropdownmenü? Ich verstehe Dein Problem nicht so ganz. Wenn Du nichts in der JS Datei geändert hast und das Skript DB basierend ist, dann hast Du evt. durch das Löschen in der DB eine Fremdschlüsselbeziehung zerstört.



  • @flenders
    Ist ein guter Tip habe was genau ist da falsch und was muß ich eingeben damits wieder stimmt? kannst du die zeile mal korrigieren und dann posten?

    @Magoon
    Wie stellt man den eine Fremdschlüsselbeziehung wieder her?



  • Ohne Dein Datenmodell und die Datensätze zu kennen, kann ich Dir leider nicht helfen. Aber falls dies der Fehler sein sollte, verweist irgendwo ein Fremdschlüssel auf einen anderen Schlüssel, welcher nicht mehr existiert.



  • @Magoon

    www.rosi-reisen.de/website.rar Unter diesem Link kannst du die website runterladen. Könntest du dir das problem mal ansehen und vielleicht versuchen zu beheben?



  • @vexx: So sollte es wohl aussehen:

    linkset[3]='<div class="menuitems"><a href="main.php?section=unternehmen" target="_top">Unternhemen</a></div>'
    linkset[3]+='<div class="menuitems"><a href="main.php?section=geschichte" target="_top">Geschichte</a></div>'
    linkset[3]+='<div class="menuitems">'
    linkset[3]+='<a href="main.php?section=news" target="_top">News</a><br>'
    linkset[3]+='<br><a href="main.php?section=presse" target="_top">Presseberichte</a><br>'
    linkset[3]+='</div><div class="menuitems"><a href="main.php?section=jobs" target="_top">Jobs</a></div>'
    linkset[3]+='<div class="menuitems"><a href="main.php?section=partner" target="_top">Partner-Links</a></div>'
    

    Um den eigentlichen Fehler zu finden müsstest du man den Code aus menue.php posten, der diesen Fehler verursacht 😉



  • vexx schrieb:

    www.rosi-reisen.de/website.rar Unter diesem Link kannst du die website runterladen. Könntest du dir das problem mal ansehen und vielleicht versuchen zu beheben?

    Irgendwie komme ich mit deinem rar-Archiv nicht zurecht 😞



  • @flenders

    Lade dir einfach die neuste winrar version runter dann kannst das entpacken und die datein öffnen.

    Danke für eure Hilfe erstmal ihr legt euch ja ganz schön ins zeug. 👍 👍 👍



  • Der oben gepostete fehlerhfte Code wird ja gar nicht dynamisch aus der DB generiert, sondern steht genau so in der menue.php - also einfach dort korrigieren 😉

    BTW: Ich würde nicht so großzügig mit den DB-Zugangsdaten um mich schmeißen - außerdem interessiert PHPMyAdmin in diesem Falle eh keinen 😉



  • @flenders
    Danke erstmal für den Tip wegen den phpmyadmin daten wusste nicht das sie dann offen zugänglich sind.

    Hab den Code in meiner menue.php mit dem ersetz den du oben gepostest hast aber es kommen noch die gleichen fehlermeldungen wenn ich die website betrete.



  • Kann es sein, dass du vergessen hast die geänderte Datei hochzuladen? Bei mir sieht der Output nämlich noch genau so aus, wie vorher 😉



  • hab es aufm rechner gestartet 😃
    Jetzt läufts aber noch ein kleiner fehler, wenn mal über die menüpunkte rollt klappt das menu nach oben auf und ist damit nicht mehr zu sehen es sollte sich unter den punkten öffnen.

    Aber erstmal eine dickes danke für deine Hilfe 👍 👍 👍 👍 👍 👍


Log in to reply