Dev-C++ erkennt #include <iostrem.h> nicht



  • Hallo mein Dev-C++ erkennt #include <iostrem.h> nicht woran kann das liegen? 😕



  • Es gab nie eine iostrem.h, wenn dann iostream.h. Und die ist nun auch obsolet, probier es mit #include <iostream>.



  • Sry. aber das geht auch nicht er sagt " iostream: No such file or directory. " 😕



  • Nimm einfach #include <iostream.h>. Gilt, wie schon gesagt wurde, als veraltet, aber was soll's? Warum sollte man kein iostream.h benutzen, wenn man damit gut klarkommt?



  • @Neobe: Dann ist deine mingw-Installation nicht komplett. Hast du eventuell nur die Dev-C++-IDE runtergeladen?

    @:I: Was denkst du wozu es Standards gibt?



  • woran erkenne ich den ob die mingw vollständig oder nur halb oder garnicht hab und wenn ich sie nicht habe wo bekomme ich die her?



  • Auf der Download-Seite für DevCpp (http://www.bloodshed.net/dev/devcpp.html) gibts 2 Möglichkeiten:
    1. DevCpp mit Mingw/gcc (ca. 7.5 MB)
    2. DevCpp ohne Mingw/gcc (ca. 2MB)

    Wenn also die Datei, die Du heruntergeladen hast, kleiner als 7.5 MB ist, dann hast Du die falsche Version erwischt...

    Gruss,
    Andreas



  • :| schrieb:

    Nimm einfach #include <iostream.h>. Gilt, wie schon gesagt wurde, als veraltet, aber was soll's? Warum sollte man kein iostream.h benutzen, wenn man damit gut klarkommt?

    Ääh, weil eine STL Implementation uU die veralteten Header nicht mehr unterstützt? 🙄 Afaik machen das die meisten zwar noch, das kann sich in Zukunft aber auch ändern. Zudem wurden die aktuellen Header ja nicht ohne Grund eingeführt ➡ std namespace.



  • Und was soll ich jetzt genau machen??? 😕



  • argh du hirn 🤡

    lad dir mingw runter, wenn in deinem dev-cpp verzeichnis kein ordner ist, der "include" heißt.
    dann kopier die ganzen ordner in mingw in das dev-cpp verzeichnis.
    dann schau in Werkzeuge->Compiler optionen->Verzeichnise->foo (alle) nach, ob die pfade von c++ includes usw stimmen (Dev-Cpp\include, Dev-Cpp\lib usw). wenn net pass sie an.
    am besten ist, du setzt noch umgebungsvariablen Dev-Cpp\bin Dev-Cpp\include dann geht nichts mehr schief



  • Schon mal
    #include <iostream>

    using namespace std;

    probiert


Log in to reply